1
Vote

Compatible for VS 2010?

description

Hello,
 
So I wanted to see if this tool would work for VS 2010 but as soon as I open the .exe (I've tried both the 08 version in an unzipped folder so it has it's config file and the 05 version) I instantly get an "EventSubscriptionTool has stopped working" error.
 
I'm wondering if it's because I have VS 2010 or if the tool is just not working?
 
Also - perhaps I need to put the tool in a special folder? I didn't see any instructions to do so though...
 
Thanks!

file attachments

comments

rohitsabhlok wrote Apr 11, 2012 at 12:27 PM

Hi

I am also seeing this issue. Looks like "EventSubscriptionTool" tool requires version 9.0.0.0 of assembly Microsoft.TeamFoundation whereas in VS 2010 we have version 10.0.0.0 of Microsoft.TeamFoundation
Please see the attached image Error.png

The file EventSubscriptionTool.exe.config has following

<assemblyIdentity name="Microsoft.TeamFoundation"
                        publicKeyToken="b03f5f7f11d50a3a"
                        culture="neutral"/>
<bindingRedirect oldVersion="8.0.0.0"
                       newVersion="9.0.0.0"/>

wrote Feb 14, 2013 at 2:10 AM

rushfrisby wrote Jul 17, 2015 at 6:21 PM

I recompiled with .net 4.5 with latest assemblies and made one change since there was a type that was obsolete in the new libraries. You can download here:

http://rushfrisby.com/wp-content/uploads/2015/07/EventSubscriptionTool.zip